10 июня 2012 г. Twitter клиент для Ubuntu

Подбирая twitter клиент для Ubuntu я остановил свой выбор на Spaz. Spaz - это twitter клиент, работающий с использованием Adobe Air. ИМХО это лучший клиент для Linux

Вот так выглядит мой Spaz:

К сожалению Adobe Air больше не поддерживается Linux, тем не менее последняя доступная версия довольно стабильно работает в связке со Spaz. Как установить Spaz для Ubuntu?

Для начала нужно установить Adobe Air. Если нужно установить на 64 bit-ую систему, то нужно предварительно установить ia32-libs, в Ubuntu это можно сделать следующим образом:

sudo apt-get install ia32-libs

после чего можно скачать и установить Adobe Air

cd /tmp
wget http://airdownload.adobe.com/air/lin/download/2.6/AdobeAIRInstaller.bin
chmod +x AdobeAIRInstaller.bin
sudo ./AdobeAIRInstaller.bin

Теперь можно запустить Adobe AIR Application Installer, после чего выбираем файл SpazAIR.air и устанавливаем его. Возможно возникнет ошибка: "Sorry, an error has occured. Adobe AIR could not be installed. Install either Gnome Keyring or KDE KWallet before installing Adobe AIR." В этом случае делаем следующее:

locate libgnome-keyring.so
/usr/lib/i386-linux-gnu/libgnome-keyring.so.0
/usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0
/usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0
/usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0

Создадим символические ссылки, согласно предыдущим результатам:

sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 \
/usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 \
/usr/lib/libgnome-keyring.so.0.2.0

После чего пробуем установить Spaz через Adobe AIR Application Installer снова. В случае успешной установки удаляем ранее созданные символические ссылки для Adobe AIR:

sudo rm /usr/lib/libgnome-keyring.so.0
sudo rm /usr/lib/libgnome-keyring.so.0.2.0

После того как запустился Spaz нужно будет авторизовать его в Twitter и после этого можно пользоваться Twitter клиентом.

P.S. Данный способ установки подходит не только для Ubuntu, но и для других версий Linux

Linux